WordPress en peligro por la vulnerabilidad Ghost

Por: David Valero
Hace un par de días saltaba la noticia acerca de una nueva y grave vulnerabilidad descubierta en Linux que podía traer peores consecuencias que el temido Heartbleed. Ha sido bautizada como Ghost y lejos de solucionarse, vuelve a la palestra al conocerse que podría afectar a aplicaciones que usan el lenguaje PHP, como WordPress, la plataforma para crear webs y blogs usada por millones de personas en todo el mundo.

Aunque la vulnerabilidad pudiera llevar presente en las versiones glibc desde el año 2000, tal y como informaron los analistas de Qualys, la compañía de seguridad que descubrió este nuevo bug, no ha sido hasta que se ha descubierto el efecto que podría tener en equipos con sistema operativo Linux, -que quedarían expuestos al control remoto por parte de un atacante-, cuando se han tomado cartas más serias en el asunto.

Pero si este problema se pensaba que podría estar acotado y afectar en menor medida a los usuarios particulares, ahora el escenario se torna más sombrío al detectarse que la vulnerabilidad también afectaría al lenguaje PHP, usado por multitud de sitios web, entre ellos WordPress. Marc-Alexandre Montpas, uno de los investigadores de seguridad que están siguiendo to el caso Ghost más de cerca, considera que WordPress tiene un gran problema por delante ya que al usarse la función wp_http_validate_url() para validar cualquier pingback, esto podría ser usado por cualquier pirata informático para insertar una URL maliciosa con el objetivo de obtener el control del servidor de la página.

vulnerabilidad
WordPress está a la espera de una solución definitiva para Ghost

Como ya os comentamos, Ghost afecta a softwares como Apache, Nginx o MySQL, entre otros, y que son utilizados por la práctica totalidad de los servidores de Internet. Por lo que es un problema serio que debe ser subsanado cuanto antes. De hecho muchas distros han comenzado a lanzar actualizaciones con el objetivo de proteger los sistemas.

En cuanto a WordPress, se recomienda el uso de plugins para desactivar el proceso XML-RPC o bien desactivar las peticiones pingback

add_filter( ‘xmlrpc_methods’ , function( $methods’ ) { unset( $methods[ ‘pingback.ping ] ); return $methods; } );

Para saber si podemos estar expuestos a esta vulnerabilidad los administradores de un servidore pueden ejecutar el siguiente código PHP en y si recibimos un error es que dicho servidor Linux es vulnerable a Ghost.

php -r ‘$e=”0″;for($i=0;$i<2500;$i++){$e=”0$e”;} gethostbyname($e);’ Segmentation fault

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>